Problemas con Acer Aspire One D250, Ubuntu Lucid Remix y grub

Hace unos días me prestaron un Acer Aspire One D250, muy mono por cierto, al que le instalé desde un pendrive (¿quien carajo quiere ya los CD/DVDs?) la Ubuntu 10.04 Remix para NetBooks. La verdad es que probé cuatro distribuciones, la Ubuntu Lucid desktop, Jolicloud (que no me gustó nada), Meego (simplemente no me funcionó) y la Lucid para netbooks, que es la que tiene ahora. Toda la instalación fue muy transparente, rápida y sencilla, hasta que decidí reiniciar. Simplemente, no arrancó. Hice mil pruebas y nada. Estaba claro, algo pasaba con el grub. Googleé un poco y encontré gente con el mismo problema pero sin solución. Al final, rejunté toda la información para darle arreglo y este es el resultado:

Lo primero es arrancar con el pendrive en modo live y acceder a un terminal. La idea es cambiar un parámetro del grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash hpet=force nolapic"

pero antes hay que acceder a la partición del disco donde está y activar los cambios con update-grub. Para ello, en el terminal teclear todo esta lista de comandos

sudo fdisk -l
sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo mount --bind /dev/pts /mnt/dev/pts
sudo chroot /mnt
sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo grub-install /dev/sda

Si falla esto último comando, reinténtalo de esta forma

sudo grub-install --recheck /dev/sda

Ahora sí, vamos a modificar la confi del grub

gksudo gedit /etc/default/grub

Y añade esto a la línea GRUB_CMDLINE_LINUX_DEFAULT

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash hpet=force nolapic”

salva y

sudo update-grub

y ya acabando

exit
sudo umount /mnt/dev
sudo umount /mnt/proc
sudo umount /mnt/sys
sudo umount /mnt

Ahora arranca de nuevo y ya debería funcionar. Espero os sirva.

Esta web utiliza cookies puedes ver aquí la política de cookies. Si continuas navegando estás aceptándola